เป็นเวลายาวนานที่ แอปเปิ้ล (Apple) ได้ติดตั้ง Python 2 มาพร้อมกับ macOS รุ่นก่อน ๆ แม้ตัว Python 2 นั้นจะเลิกสนับสนุนมาตั้งแต่ 1 มกราคม 2020 โดยล่าสุดใน macOS 12.3 ที่แอปเปิ้ลปล่อยให้นักพัฒนาและผู้ใช้ที่สนใจได้ทดสอบกัน มีการถอดออกไปเรียบร้อยแล้ว

แอปเปิ้ลระบุว่านักพัฒนาควรเปลี่ยนไปใช้งานภาษาสคริปต์อื่น เช่น Python 3 รุ่นที่ใหม่กว่า ซึ่งจะไม่ได้ถูกติดตั้งมาพร้อมกับ macOS โดยสามารถติดตั้งได้ผ่านการติดตั้งเครื่องมือ Xcode สำหรับนักพัฒนา ที่มีการรวมตัว Python 3 นี้ด้วย

ก่อนหน้านี้แอปเปิ้ลเคยเตือนนักพัฒนาแล้วว่าจะมีการถอด Python 2.7 ออกไปใน macOS เวอร์ชันในอนาคต ตั้งแต่ macOS Catalina แต่สาเหตุที่ยังคงต้องมีการติดตั้งมาใน macOS รุ่นก่อน 12.3 นี้ เพราะยังคงต้องรองรับแอปเก่า ๆ อยู่

แอปเปิ้ลได้แนะนำว่า หากโปรแกรมของนักพัฒนามีการใช้ภาษาสคริปต์ต่าง ๆ ควรบันเดิลรันไทม์เข้ากับตัวโปรแกรมเลย ให้สามารถรันได้ด้วยตัวเอง

อ้างอิง: MacRumors

พิสูจน์อักษร : สุชยา เกษจำรัส

เราใช้คุกกี้เพื่อพัฒนาประสิทธิภาพ และประสบการณ์ที่ดีในการใช้เว็บไซต์ของคุณ คุณสามารถศึกษารายละเอียดได้ที่ นโยบายความเป็นส่วนตัว และสามารถจัดการความเป็นส่วนตัวเองได้ของคุณได้เองโดยคลิกที่ ตั้งค่า

Privacy Preferences

คุณสามารถเลือกการตั้งค่าคุกกี้โดยเปิด/ปิด คุกกี้ในแต่ละประเภทได้ตามความต้องการ ยกเว้น คุกกี้ที่จำเป็น

Allow All
Manage Consent Preferences
  • Always Active

Save